Авторизация

Логин:
Пароль:
Восстановить пароль
Регистрация
  • Форум
  • Блоги
  • Контакты
  • Новости
  • Продукты
  • Отрасли
  • Обучение
  • Поддержка
  • События
  • О компании
  • Доступ к растровым изображениям, документам и Web сайтам из ArcMap

    По статье Моники Пратт в журнале ArcUser, апрель-июнь 2001 г.

    Встроенная в ArcMap функциональность предоставляет широкие возможности установления связей карт с разнообразной информацией. Привязка других документов к объектам карты, таких как растровые изображения и Web страницы, помогает организовывать и устанавливать ссылки на связанные информационные ресурсы. ArcMap, одно из трех десктоп-приложений, входящих в состав ArcInfo 8, позволяет обращаться к файлам различных типов, используя гиперссылки.


    Выбрав инструмент Идентификации (Identify), щелкните в Виде на полигоне Национального парка Джошуа (Joshua Tree NP). В окне Результаты идентификации (Identify Results) щелкните правой клавишей мыши на Joshua Tree NP.

    Гиперссылки быстро и просто создаются в ArcMap. Ниже дается краткое описание того, как связать объекты на карте с файлами, созданными в других прикладных программах, без написания собственных программных кодов. В следующих упражнениях используются примеры данных, приведенные в статье "Горячие связи в ArcView GIS" из номера журнала ArcUser за январь-март 2001 г. (см. www.esri.com/arcuser, а также www.esri.com).


    В диалоговом окне Добавить гиперссылку (Add Hyperlink) выберите опцию Связать с документом (Link to a Document) и выберите файл Joshua.tif.

    Если Вы уже выполняли упражнения по созданию горячих связей (hot links) в ArcView GIS, то можете использовать те же файлы и структуру каталогов. Если Вы не выполняли этих упражнений или удалили исходные файлы, загрузите самораскрывающийся заархивированный файл и используйте Windows Explorer для создания каталога под именем hotlink в корневом каталоге или недалеко от него. В этом каталоге создайте две папки с именами shpfiles и images. Поместите шейп-файлы ca_parks и ca_outline в папку shpfiles. Поместите три файла растровых изображений с именами death.tif, joshua.tif и yosemite.zip в папку images.


    Щелчок на полигоне Национального парка Джошуа инструментом Гиперссылка (Hyperlink) вызывает появление связанного изображения (файла joshua.tif) в отдельном окне.

    Для работы потребуется программа ArcInfo 8 или ArcGIS 8.1, а также действующее подключение к сети Интернет.

    Установка связи с изображением

    1. Запустите ArcMap. В диалоге запуска выберите опцию Создать новую карту (Create a New Map) и нажмите Начать работу (Start using ArcMap).
    2. Добавьте шейп-файлы ca_parks и ca_outline как слои карты, выбрав опцию Добавить данные в меню Файл (File > Add Data), либо щелкнув на кнопке добавления данных в панели инструментов Стандартные (Standard).
    3. Убедитесь, что панель Инструменты (Tools) доступна. Если нет, выберите Вид>Панели инструментов (View > Toolbars) и подключите ее.
    4. Выберите инструмент Идентифицировать (Identify) из панели инструментов Tools. На этом инструменте показан значок в виде буквы "i", заключенной в кружок.
    5. Выберите инструмент Идентифицировать и щелкните на полигоне Joshua Tree National Park. Этот объект, обозначенный как "Joshua Tree NP", будет отображен под слоем ca_parks в диалоговом окне Результаты идентификации (Identify Results).
    6. Щелкните правой клавишей мыши на Joshua Tree NP в диалоговом окне Результаты идентификации (Identify Results) и выберите опцию Добавить гиперссылку (Add Hyperlink) из контекстного меню.
    7. В диалоговом окне Добавить гиперссылку выберите опцию Связать с документом (Link to a Document) и щелкните на кнопке со значком эллипса. Найдите файл Joshua.tif в папке изображений images, которую Вы создали ранее. Щелкните на файле joshua.tif. Нажмите OK, чтобы закрыть диалоговое окно.
    8. Для использования гиперссылки, щелкните на инструменте Гиперссылка (Hyperlink). На этом инструменте нарисован значок молнии. Выбрав инструмент Гиперссылка, нажмите на полигон Joshua Tree Park. Связанное изображение joshua.tif будет открыто в окне приложения для работы с изображениями, установленного на компьютере.


    В ArcMap для одного объекта можно установить несколько гиперссылок на растровые изображения или Web сайты.

    Установка связи с Web сайтом

    ArcMap может управлять несколькими связями одного объекта с разными типами документов. Это означает, что связь с сайтом Национального парка Джошуа можно задать без удаления связи с растровым изображением на область этого парка joshua.tif.

    1. Снова выберите инструмент идентификации Identify. Щелкните на полигоне национального парка Джошуа (Joshua Tree National Park).
    2. Щелкните правой клавишей мыши на Joshua Tree NP и выберите опцию Добавить гиперссылку (Add Hyperlink) из контекстного меню.
    3. В диалоговом окне добавления гиперссылок (Add Hyperlink) выберите связь с сайтом (Link to URL). Введите желаемый URL в это текстовое поле, или скопируйте его из поля адреса браузера в буфер обмена (clipboard) и затем вставьте. Адрес URL Национального парка Джошуа следующий: http://www.nps.gov/jotr/. Нажмите OK, чтобы закрыть диалоговое окно.
    4. Проверьте установленную гиперссылку, щелкнув на полигоне Национального парка Джошуа. Поскольку с этим полигоном связано более одного документа, появится диалоговое окно Гипессылки (Hypelinks). Выберите URL Web страницы и нажмите на кнопку Перейти (Jump). Будет запущен заданный по умолчанию браузер, и откроется нужная Вам Web страница.


    То же диалоговое окно добавления гиперссылок (Add Hyperlink) можно использовать для связывания объекта с Web сайтом.

    Имейте в виду, что растровые изображения и другие связанные документы будут открываться в программе, заданной в вашем компьютере для работы с соответствующим типом файлов. Соответственно, изображения парков в формате TIFF в данном упражнении будут открыты в заданной у вас программе для работы с графикой. Это также, в отличие от ArcView GIS, означает, что для просмотра документов в других приложениях, таких как Microsoft Word, не нужно писать дополнительные программы (скрипты). Просто нужно создать гиперссылку на документ, действуя так же, как при создании гиперссылки на изображение. Выбор опции управления гиперссылками (Manage Hyperlinks) в том же контекстном меню, используемой для добавления гиперссылок, открывает диалоговое окно динамических гиперссылок (Dynamic Hypelinks), в котором Вы можете редактировать гиперссылки для объектов карты.


    После выбора гиперссылки на URL будет запущен заданный по умолчанию браузер, и в нем откроется заданная вами Web страница.

    Установление гиперссылок представляет собой лишь один пример использования многочисленных инструментов ArcMap для интегрирации данных и автоматизации решения задач. За дополнительной информацией по использованию ArcMap обратитесь к Getting to Know ArcGIS Desktop - новой книге, выпущенной издательством ESRI Press. Ее описание можно посмотреть на странице www.esri.com/gisstore.


    Вернуться к списку